No announcement yet.

Xbox 360 Update released - Achievement Issue & Freezing should be fixed

  • Filter
  • Time
  • Show
Clear All
new posts

  • #31
    We did hear from one user who was having repeated freezes during a You Monster SuperGrinder that when they deleted the game and DLC then redownloaded them both they did not have the freezing issue afterwards. I'm not exactly sure why, but am passing that along.


    • #32
      jeffpobst, I have an update I think you might be interested in.

      As I said, I have been getting the message about not being able to award achievements due to not having enough space on my storage device after every mission I played. Well, I moved my saves to USB drive (not sure if this matters) and deleted and redownloaded Defense Grid and the You Monster DLC.

      After I started playing, I finished the third mission, it gave me the message about not being able to award achievements, and when I exited that notification box, the "Savant Genius" achievement unlocked. I continued on playing and after many hours managed to complete the story missions (all with gold). I receieved the error message after every single mission I played (sometimes even in the middle of them) and when I finished #8, and exited the error message box, "Majestic Pony" and "You Monster" unlocked.

      I completed the remaining story challenges I had left to do, still getting the error message after each one, and the "Best Friends Forever" achievement unlocked.

      My point of all this being that even though the error message of not being able to award achievements keeps showing up, the achievements are still being tracked and unlocking properly.

      Besides this, I have one major issue since the update. Whenever I exit back to the main menu and hit the B button by accident, taking me back to the start up screen, it locks up my whole console, forcing me to shut it down. I'm playing on a Gears of War slim, so I'm guessing that's the problem.

      One last bit of information for you. I believe I know what causes the "scamyoumonster" problem. I received that error yesterday and I thought about what I might have done differently while launching the game. My answer was that I pressed my guide button. I tested it and sure enough every time I hit my guide button while the game was booting up, I got the "scamyoumonster" message once I was loaded in.


      • #33
        Thanks for all the details.

        Some info that may help you decipher things: The achievement error wording is confusing, but it is specifically what we have to put on the message box by Xbox technical certification requirements. Basically, you get the error message any time the game checks an achievement ID and the back-end database doesn't know about that achievement (when it should). If, for example, part of the back end listing of achievements was corrupt for just one achievement that you have earned but not received, you'll get an error message sadly every time it checks for any achievements. So, it may only be one acheivement - might even be an achievement from an earlier expansion as there is only one list for all acheievments that has to be replaced any time new ones are added - that is causing your dialog to pop up.

        We know that all the id's are correct with the back-end data we are given from Microsoft and we tested it on a test environment called partnernet where it has only one back-end database to my knowledge, and we never saw error messages when we were connected to it. But, I'm suspecting that not all data centers on the production environment have the same info, and one mismatch would cause the error to come up even if all other achievements are being awarded (as you are observing).

        The guide button makes sense, in that the game is required to stop working when the guide comes up, so that can cause the game to stop loading, and then when you return, for some reason that we don't know yet, after the new dash, the game thinks "I'm done loading" when it isn't done loading. The guide button is a particular way you as a user can delay loading, and help cause the issue. I'll see if we can duplicate that in the test environment - I think our testers did try that when we were trying our best to duplicate the issue, but I'll verify that.

        One other clue is that the slim boxes seem more susceptible to issues than others by report. That simply may be statistics that more people buying the game are on slim boxes, or there may be something there too - something for us to pay attention to when we can figure out if there is more going on than just bad back-end data.



        • #34
          Another update from myself.

          I finished the You Monster Expansion and was correctly awarded both the "Majestic Pony" and "You Monster" achievements. However, "Beating a Dead Potato" still remains locked.

          Still getting the "failed to award achievement" message, but I haven't had any more lock-ups since deleting and re-downloading.

          Hope this info helps.


          • #35
            Originally posted by jeffpobst View Post
            One other clue is that the slim boxes seem more susceptible to issues than others by report. That simply may be statistics that more people buying the game are on slim boxes, or there may be something there too - something for us to pay attention to when we can figure out if there is more going on than just bad back-end data.

            A bunch of my friends (myself included) are experiencing these issues on standard 360 Elite consoles.


            • #36
              Well, after many hours of re-trying, I finally got my 35 gold medals, and can confirm that "Beating a Dead Potato" also unlocks correctly.

              I tried my game out on my other two Xboxes (60gb Pro and an old standard arcade) and didn't receive the error message on either of them.


              • #37
                Over the Christmas Holiday, I was at the inlaws. So I recovered my profile, and downloaded DG freash on a new system. Then I downloaded all the content and started to play. Right in the middle of a level, BANG ! It froze, and announced that one or more achivements couldnt be awarded and that I was either disconected from XBL or my storage device was full.

                This was on a new xbox slim with hard drive. I think it has like 220g free.

                So, no, the game isnt fixed.


                • #38
                  Still Not Working (cross-post)

                  I wasn't sure how to cross-post between forums so I am doing it the old- fashioned way. I just posted to the "What we Know as of the 17th" thread, but this one looks to be more active, I wanted to post here as well:

                  First off, I have gone through the grab-the-latest-update-it-failed-and-then-deleted-and-completed-the-complete-download dance.

                  While I have to say that I am happy I got to play for about two hours this morning, this is the first time that the game has worked since 17 December. Unfortunately, I have no idea what voodoo was invoked in order to play the game. More often that not, the game goes into what I call a Black Screen of Death - screen goes black, nothing happens (drive in the XBox even seems to spin down) and I need to do a hard reset (button on the Xbox itself) to get it to come back. This afternoon, I was able to get to the Xbox Live Arcade screen before everything froze (no music).

                  I have to say, this is getting supremely frustrating.


                  • #39
                    I agree it is frustrating. Nothing has changed since the 22nd to my knowledge. The Microsoft folks who will have the ability to affect change return from their vacation tomorrow as I understand it.


                    • #40
                      achievement not awarded

                      I am still getting the achievment not awarded message - has there been any more information regarding this fix?


                      • #41
                        More communication with Microsoft this week, but no fix as of yet. I wish it was moving to solution faster as well. So far we're talking with the right people, but not making the progress we'd like. We'll keep at it.


                        • #42
                          Thanks for the update, seems to have taken a poke to get it though or am I being unfair? Oh no, I hope I'm not becoming all bitter and twisted.


                          • #43
                            I started it up tonight, had to download another update, and I was able to play through three levels without any locking up or crashing. I did get the "unable to unlock achievement" message during one level (probably one of the ones I already have -- I have all of the non-You Monster achievements unlocked already). The last level I played, I finally got a gold medal, and Savant Genius unlocked.

                            The unable to unlock achievement message is an annoying interruption, but at least it can be dismissed relatively quickly.


                            • #44
                              game freezes, achievement error msg mid-game.

                              I've had the game well over a year, you monster a month or two. I never had a problem until a week ago with the error message about achievements not being awarded at the end of a game. Now I am getting achievement error msg very early DURING the game and/or the game is now freezing completely. Some of this seems to be connected to the right button for speeding up action. So why am I only experiencing trouble NOW after all this time of being error free?


                              • #45
                                Achievement and Freezing Issues

                                I have received the achievement error for over a year...

                                Tonight I:

                                1) Deleted my profile, the game, and its DLC.
                                2) re-downloaded all the above.
                                3) Still received the error and the game was constantly freezing.
                                4) Deleted everything again
                                5) Re-downloaded the Core game only
                                6) Still receiving the achievement error but the freezing stopped
                                7) Downloaded just Map #4 DLC (Missing only the Overflowing achievement in first 4 map packs.
                                8) I still get the achievement error but the freezing has stopped.

                                I rinse and repeated this on three different Xboxes tonight.

                                I can re-produced this at will. There is no reason this should not be troubleshoot-able. I no of no other games with this issue. If Hidden Path wants I can provide written permission to work with Microsoft and access my gamertag (NeoRatt) to get my gamertag data and troubleshoot this.